[flocking-users] Newbie

Colin Clark colin at colinclark.org
Mon Nov 11 10:54:55 EST 2013


Hi Roger,

I'm glad to hear that you're experimenting with Flocking. From the error you're receiving, it looks like perhaps you have omitted the Fluid Infusion dependencies required by Flocking. Probably the easiest way to link to Flocking is to make a build, which will create a single file containing all required dependencies.

I've updated the Flocking README file to include instructions on how to make a build:

https://github.com/colinbdclark/Flocking#getting-started

And also, if you want, how to link to the individual files:

https://github.com/colinbdclark/Flocking#using-individual-flocking-files-for-development

Let me know if this works for you, and if there's any other documentation I can add to help make the process of getting started with Flocking easier.

Colin

On 2013-11-11, at 1:48 AM, roger pibernat <rogerpibernat at gmail.com> wrote:

> Hi,
> 
> I'm completely new to Flockingjs.  I'm trying to use it for the first time.  I included all the .js files in my index.html code, but I get the following error:
> 
> 	• Uncaught ReferenceError: require is not defined flocking-core.js:15
> 
> What library am I missing?
> 
> Cheers!
> 
> Roger
> 
> (+34) 639 81 26 71
> http://www.rogerpibernat.com
> http://www.wucollective.com
> _______________________________________________
> users mailing list
> users at lists.flockingjs.org
> http://lists.flockingjs.org/listinfo.cgi/users-flockingjs.org




More information about the flocking mailing list