on the meaning of "the uPortal Layout Manager"
a.cheetham at utoronto.ca
Thu Feb 14 16:06:00 UTC 2008
On 14-Feb-08, at 10:40 AM, Antranig Basman wrote:
> I think the whole association of the component with "portlets" at all
> is somewhat unfortunate and I would like to see it banished from the
I agree wholeheartedly.
> My suggestion is calling it the "Cellular Layout Manager", to go
> alongside the "List" and "Grid" layout managers.
Hm... 'cellular' sounds a bit biological to me :-)
> .. we could then
> rename "Column" wherever it occurs in the code to "Cell" and then
> also rid ourselves of this persistent "up/down" "left/right"
> coupling (although perhaps it is helpful to coders when visualising
> what they are writing).
Unless I'm misunderstanding what you mean when you say "up/down left/
right coupling" (which is entirely possible!) I don't think it's
reasonable to try and get rid of it. A prime purpose of this code is
to provide keyboard accessibility, and the keyboard functionality is
based on up/down and left/right movements.
Am I misunderstanding you?
> The name "cell" isn't great since it is possibly open to confusion
> with the "individual" cells which may be moved around.
It also may be confused with table cells, which is inaccurate in that
it is too restrictive.
> If we keep talking of this in terms of portlets, the virtually
> limitless potential of this new component I fear may be
> perpetually obscured :P
Anastasia Cheetham a.cheetham at utoronto.ca
Software Designer, Fluid Project fluidproject.org
Adaptive Technology Resource Centre / University of Toronto
More information about the fluid-talk