on the meaning of "the uPortal Layout Manager"

Joseph Scheuhammer clown at utoronto.ca
Thu Feb 14 18:07:06 UTC 2008

> I think the whole association of the component with "portlets" at all
> is somewhat unfortunate and I would like to see it banished from the
> code.
I wholeheartedly agree.  It isn't just for portlets, although that's the 
immediate target.

I have different minor issues with "cell".

I find it easy to stop thinking about the DOM with respect to moving 
these "things" around, and rather in terms of what is on screen.  
Admittedly, those "things" relate to the DOM at some way, but that feels 
like an implementation detail.  The fact that "cell" might be confused 
with a table element "cell" (<td>) is not an issue for me.   Or, it's 
only an issue if we are restricting ourselves to DOM-speak.

The problem I have with "cell", and it's minor, is that the image 
gallery "thumbnails" can been seen as cells too.  But the image 
gallery/lightbox uses the grid layout handler.  In short, "cell" may be 
too generic.

> we could then
> rename "Column" wherever it occurs in the code to "Cell"
> ...
> The name "cell" isn't great since it is possibly open to confusion
> with the "individual" cells which may be moved around.
Indeed.  In fact, that's what I thought "cell" meant at first.  I don't 
see the columns as "cells"; rather, "cell" is a replacement for 
"portlet".  Furthermore, the cells are grouped in vertical columns.  So, 
perhaps it's a "ColumnLayoutHandler", although that doesn't exactly trip 
off of the tongue.


'This is not war -- this is pest control!'
      - "Doomsday", Dalek Leader -

More information about the fluid-talk mailing list